Indice

INTRODUCCION :
¿Que es el Optimizador de Corte Lineal?
Utilidad
Beneficios
Requisitos de Operación

MENU PRINCIPAL :
Pantalla Principal
Barra de Menu
Configuración

DATOS :
Cortes pedidos
Material a cortar
Holguras y Reutilizable
Archivo de Datos
Importar Datos

SOLUCION :
Salida de resultados
Configuración de Planilla Excel
Etiquetas Ms Word

Stocks de diferente largo


¿Que es el Optimizador de Corte Lineal?

¿QUE ES EL OPTIMIZADOR LINEAL DE CORTE?
 Previous Top Next

En muchas clases de industrias, se manejan insumos materiales como vigas, cañerias, tubos, perfiles metálicos de sección fija etc. Tales materiales están normalmente disponibles en el mercado de insumos en stocks de longitud standard fija. Sin embargo, para trabajar estos insumos, usualmente se necesita cortarlos en diferentes cantidades de trozos de dimensiones menores.

Con este Optimizador Lineal de Corte, se realiza el mejor aprovechamiento longitudinal de materiales, buscando el óptimo matemático (o su mejor aproximación en tiempo real), con rapidez y precisión, considerando incluso la variable costo, y pudiendo manejar stocks con distintas longitudes standard, de modo que si tiene en bodega trozos sobrantes, estos se pueden incluir en la optimización .

El ahorro de materiales que se logra con un plan de corte óptimo, contra programas que generan planes de corte de rendimiento promedio, hacen que el Optimizador Lineal de Corte tenga una razón beneficio/costo tal, que por ejemplo una fabrica de grandes estructuras de acero como galpones, edificios y otras , dados los precios y volumen de los materiales que se usan, se puede llegar a recuperar el costo de este software con la generación del plan de corte para una sola orden de trabajo .
Por otra parte, la herramienta está diseñada con una interfase interactiva muy sencilla, fácil de usar y entender para cualquier tipo de usuario, de modo que el aprendizaje de nuevos usuarios es rápido y productivo.


Utilidad

USO DEL OPTIMIZADOR LINEAL DE CORTE
 Previous Top Next
El uso de esta herramienta lo podemos ilustrar con el siguiente ejemplo:

Para una construcción se requiere cortar un tipo perfil C de acero en las siguientes cantidades y medidas :

 Largo(mm)   Cantidad
  4156          7
  3741         12
  3458         25
  3251          3
  2987         28
  2865          5
  2768         10
  2368         32
  2058         12
  1646         85
  1530          9
  1500         20
  1325         21
  1004         20
   832         85

El insumo para hacer esos cortes son perfiles que se compran en tiras de 6 mt.
¿Cuantas tiras de 6 mt se deben comprar?
¿Cual es la mínima cantidad de tiras que permite satisfacer el pedido?
¿Como obtener el los esquemas de cortes que ocupen un mínimo de tiras de 6 mt?

Las preguntas anteriores se resuelven ingresando los datos del problema al optimizador lineal de corte y obteniendo el correspondiente Resultado .

Este resultado responde las dos primeras preguntas anteriores, y es de 119 tiras de 6m.
La tercera pregunta también queda resuelta, teniendose en cada línea del cuadro la configuración del los patrones de corte y la cantidad de veces que hay que repetir cada esquema para satisfacer el pedido en forma óptima.


BENEFICIOS

El Optimizador lineal de Corte produce beneficios al proceso productivo por:
q Ahorro de materiales.
q Ahorra el trabajo de determinar los patrones de corte.
q Ahorra y facilita trabajo de taller, entregando una lista ordenada de patrones de cortes, y con con una cantidad acotada de patrones diferentes.
q Ante alternativas de proveedores, puede orientar la compra eficiente de materiales.

Para ilustrar los ahorros de materiales que se pueden lograr, veamos los resultados del ejemplo anterior ( Utilidad ) :

El total de material pedido en este caso ( suma de los trozos pedidos multiplicado por las cantidades pedidas), es de 700m.
El óptimo obtenido con nuestra herramienta significa un uso de materiales de 714m. Son las 119 tiras de 6m,lo que da una pérdida de materiales de 14m correspondiente al 2 % , respecto al gasto ideal de materiales.

Compararemos con aprovechamientos hechos sin el apoyo de esta herramienta.
En estos casos, típicamente se obtienen resultados ( dependiendo de la experiencia, habilidad y tiempo que dedique quién hace el aprovechamiento ) de 5% a 15% de pérdida.

Comparación de pérdida de materiales
% Pérdida | Pérdida [m] | Diferencia Óptimo [m]
Óptimo= 2% | 14 | 0
5% | 35 | 21
10% | 70 | 56

El mayor costo de estas diferencias depende del precio del material. Para ilustrar un par de situaciones posibles, veamos precios de US$ 3,5/m y US$ 5/m:

Costo adicional de aprovechamientos no óptimos
% Pérdida | Mayor pérdida [m] | Mayor costo a US$ 3.5 /m Mayor costo US$ 3,5/m | Mayor costo a US$ 5 /m
5% | 21 | US$ 73.5 US$ 73,5 | US$ 105
10% | 56 | US$ 196 US$ 196 | US$ 280


Requisitos de Operacion

Requisitos de Operación

Sistema Operativo:

Windows NT, Windows 95, 98, 2000, XP, Vista, 7

Hardware:

Procesador: Pentium III o superior
Memoria RAM : Mínimo 256 Mb.

Licencia:
Shareware, se puede usar en modo de prueba por 30 días gratuitamente. Durante el período de prueba la impresión y grabación de resultados está deshabilitada.

Para adquirir licencia de uso pleno ir a:
http://www.shareit.com/product.html?productid=179788

La licencia de uso completo es tambien el compromiso de 1D Solutions de dar soporte al usuario sin costo a consultas por e-mail.

Autor: 1D Solutions,
info@1d-solutions.com

http://www.1dsolutions.com
CopyRight © 1998-2010 Todos los derechos reservados


PANTALLA PRINCIPAL

Veamos la pantalla principal. Después del ingreso de datos, la pantalla lucirá como la figura que sigue:

La pantalla está dividida en rectangulos, cada uno con diferente tipo de datos. Estos rectángulos son de tamaño flexible y se pueden estirar o encoger pinchando con el botón derecho del ratón, la línea oscura de separación entre dos rectangulos.

Para obtener el plan de corte, presione el botón "RESOLVER" de la Barra de Menu .
Cuando la optimización ha terminado, aparecerá una pequeña ventana de dialogo preguntando si desea ver los resultados. La ventana de solución se abrirá en el formato previamente seleccionado (ver Salida de resultados ).

Si en otro momento desea ver un plan de corte, presione el botón SOLUCION (si no hay una optimización disponible, el botón se deshabilita ) y obtenga el plan de corte en el formato previamente seleccionado.


Barra de Menu

BARRA DE MENÚ

La barra está compuesta por los siguientes botones :

Archivos:
Con este botón se despliega un pop-up menú con las opciones :
- Cargar: Para abrir un Archivo de Datos y cargarlo en la pantalla de ingreso de datos.
- Grabar: Para grabar los datos de la pantalla en un Archivo de Datos .
- Imprimir: Prever e Imprimir los datos de entrada.
- Unidades: Para elegir entre notación fraccional en pulgadas o decimal en qualquier otra unidad de medida.
- Opciones: Configuración del Sistema
Resolver:
Presionando este botón se ejecuta la optimización de los datos ingresados en pantalla. El botón se habilita cuando se han ingresado datos.

Solución:
Este botón sirve para desplegar la solución obtenida y se habilita despues de activar el botón RESOLVER. Posee un por-up menú lateral para elegir el formato de reporte para desplegar la solución. Las opciones de formatos de reporte son:

Limpiar:
Botón para borrar los datos ingresados en el pantalla principal.

Ayuda:
Despliega esta ayuda.

Salir:
Terminar la ejecución del programa.

Acerca de...:
Abre una ventana que muestra información acerca del programa: número de serie, versión, licencia, e-mail de soporte.


Configuracion

Configuración

Unidad de Medida:
Se especifica la unidad de medida básica ( por ejem. Milímetro) y puede especificar una medida agregada ( por ejem. Metro) y el factor de agregación o multiplicación de la unidad básica que equivale a la medidca agregada ( por ejem. metro = 1000 milímetros)

Impresión:
· Elegir orientación y tamaño del papel.
· Especificar el caracter que se usará como separador de las medidas de trozos para el reporte de solución formato textol.
· Elegir si el reporte gráfico detallado mostrará los ángulos de corte a escala. Esta opción queda deshabilitada si la opción para incluir datos de "angulos de corte" no está habilitada (ver Configuración ).

Etiquetas:
Formato para imprimir una etiquetas para cada trozo cortado. Se especifica Margen Superior , Margen Izquierdo, Altura por etiqueta y Ancho por etiqueta.

Directorios:
Especifica la ubicaci{on de algunos directorios usados en el programa.

General:
· Elegir si se muestra o no la lectura flotante de indicaciones acerca del elemento donde se posa el cursor de ratón.
· Determinar si desea incluir los ángulos de corte de los trozos en los datos.
· Definir que caracter se usará como separador en los archivos de entrada y salida con formato CSV ( permite mas flexibilidad para compatibilizar con programas de planila de cálculo).
· -n las cajas amarillas con texto de ayuda en los controles de pantalla.

Configurar salida a excel:
Permite diseñar la forma de la planilla en que puede cargar directamente el plan de corte resultante (ver Configuración de Planilla Excel ).


Cortes pedidos

TROZOS PEDIDOS

En este recuadro se ingresan los datos correspondientes a los distintos trozos que se desea cortar desde el material original. Después de ingresados los datos, las filas se reordenarán por longitud luego de sacar el cursor del recuadro. ( Ver ).
Los datos a ingresar obligatoriamente por cada trozo pedido son :

Largo : Longitud del trozo a cortar .

Cantidad : Cantidad de trozos con estas características (largo, y optativamente marca, ángulos en extremos).

Tambien se puede ingresar opcionalmente:

Marca : Marca de identificación del trozo.

Angulo de Corte Extremo Izquierdo,
Angulo de Corte Extremo Derecho :
Indican el ángulo de inclinación con que se debe cortar el extremo del trozo.

Estas dos últimas columnas se pueden hacer aparecer o no en la grilla de ingreso de datos, de . acuerdo a la preferencia elegida en el menú de Configuración .


MATERIAL A CORTAR
En este panel se deben consignar las características de las barras a cortar (ver Comandos de ingreso ).
Los datos a ingresar por cada tipo de barra son :

Largo : Longitud de la barra ( en mm ).

Cantidad : Cantidad de barras que se dispone en stock para cortar. En el caso de se desee dimensionar la compra de material (no hay stock propio ) de una barra, basta poner aquí una cantidad que sea suficientemente grande ( p. Ej. 100000 ), representando el stock del proveedor.

Costo : Costo por metro ( o unidad de medida) del material para cada tipo de barra. Cuando los materiales son de distintos fabricantes y vienen en barras de diferente longitud, es de interés revisar cual es la mezcla de estos materiales que nos da el óptimo mas económico. Ingresando estos datos con valores diferentes por tipo de barra, el optimizador incluirá el factor costo para hacer la optimización. También esto es útil si hay sobrantes que se desea aprovechar (a los materiales sobrantes se les asigna usualmente un costo inferior al stock normal).

.


Holguras y Reutilizable

HOLGURAS y MINIMO TROZO REUTILIZABLE
Espesor de Corte:
Holgura que se agregará a cada corte, de acuerdo a la pérdida de material causada por la herramienta de corte. Normalmente esto equivale al espesor de la sierra o instrumento con que se cortan los trozos.

Exceso en Extremos :
Holgura que se restará en cada extremo de las barras sobre las cuales se va a trozar. De modo que el largo efectivo sobre el que se realizará el aprovechamiento será el largo de la barra menos dos veces esta holgura (una por cada extremo).

Reutilizar Sobrantes Mayores a:
Determina la longitud que separa los sobrantes de corte que irán a chatarra (menores) o se almacenarán para utilizar en otras órdenes de corte ( mayores o iguales).

Estos parámetro quedan grabados cada vez que se modifican, y por omisión el sistema trabaja con el último valor que se grabó.


ARCHIVO DE DATOS

Los archivos de datos que graba y lee el optimizador de cortes, estan esritos en formato CSV (Comma Separated View), de modo que puede usarse MS Excel para leerlos y grabarlos , usando la opción "Grabar como.." de Excel para elegir el formato de salida ( .csv).

Para que el programa pueda leer un archivo de datos, este debe estar estructurado como el de la figura que sigue:

Las palabras que están encerradas en las elipses, son las que permiten al programa conocer que tipo de datos vienen en el bloque a continuación, de modo que es obligatorio ponerlas en esa ubicación previa a cada bloque de datos. Estas palabras son exactamente las mismas que se ocupan en pa pantalla de ingreso de datos.

Los bloques de datos deben separarse por ( al menos) una linea en blanco y pueden ingresarse en cualquier orden. El único bloque imprescindible es el de trozos.


IMPORTAR DATOS
PASOS PARA IMPORTAR DATOS:

Adquisición de los datos:
- Con una planilla electrónica (excel u otra) abierta o tambien desde un editor de texto si es un archivo CSV, seleccione con el ratón un rectangulo que contenga las celdas que le interesan
- Presione el botón derecho del ratón, y le mostrará el menú de opciones
- Seleccione la opción "Copiar"

Conección con 1D-Nest:
- Abra la pantala principal del programa 1D-Nest
- Con el cursor del ratón, apunte la planilla de entrada de datos para "Cortes pedidos" o "Material a Cortar" y presione el botón derecho del ratón.
- Entonces se abre un cuadro de dialogo para confirmar la importación, hágalo presionando "Ok". ( Si no ha seleccionado datos previamente, este dialogo simplemente no aparece )

Ventana para seleccionar las cloumnas de datos que se importan

Moviendo los datos al optimizador:
- El programa abre una nueva ventana, mostrando los datos seleccionados para importación en una planilla.
- Seleccione e identifique las columnas y contenido a importar apuntando con el ratón, la celda que encabeza la columna y selecionando de el tipo de dato que contiene la columna. Las columnas con datos irrelevantes déjelas con su encabezado en blanco y serán ignoradas.
- Despues de hacer la selección de columnas, presione el botón OK y los datos pasarán a la pantalla principal del programa. En este momento también se hace una verificación de los datos numéricos y si hay error, se detendrá el proceso para que correja las celdas con datos numéricos no válidos.

Origen de los Datos:
- Si los datos provienen de una planilla de calculo (Excel u otra) seleccione el recuadro que está a la derecha del encabezado , la opción "Planilla de calculo", si ha seleccionado de un archivo separado por comas (CSV), seleccione "Archivo CSV".
Para los archivos CSV aparecerá un cuadro para indicar cual es el caracter separador que se usa en el archivo importado.


Salida de resultados

OPCIONES DE SALIDA DE RESULTADOS

Cuando se presiona el botón "Solucion" , se mostrarán los resultados de la optimización de corte en la forma que Ud. ha escogido en el menú de opciones de salida de resultados anexo al botón (apuntar la flecha del botón). Este abre las ventanas de resultado siguientes:

Las opciones de ventanas de salida son como se ve en la imagen:

- Esquemas de corte detallados:

Muestra un esquema gráfico para cada patrón de corte detallando los datos de cada corte.

- Esquemas de corte:

Muestra la reporte con esquemas gráficos de cada patrones de corte.

- Plan de corte

Genera una lista de patrones de corte, mostrando longitudes de cada corte.

- Resumen:

Total de materia prima requerida para el plan de corte y detalle de recortes reutilizbles.

- Planilla Excel:

Abre el programa Ms Excel, poniendo los resultados en una planilla. El formato de esta planilla se puede manejar de manera flexible posibilitando al usuario usar sus propios diseños de planilla de resultados, ver Configuración de Planilla Excel . El botón para entrar a la configuración de planilla aparece cuando selecciona "Planilla de cortes". Esta opción solo funciona si tiene Microsoft Excel instalado en su computador.

- Lista de Etiquetas:

Abre la lista de etiquetas con datos de cada corte, según lo especificado en Configuración .
- Ms Word Labels :

Abre con la aplicación MsWord un archivo plantilla de etiquetas (previamente creado), y le traspasa internamente un archivo con los datos de las etiquetas que se combina con la plantilla. El archivo plantilla de etiquetas se puede crear usando la herramienta "combinar correspondencia" de Word.

Esta opción solo funciona si tiene Microsoft Word instalado en su computador.


Configuracion de Planilla Excel

FORMATO DE RESULTADOS EN PLANILLA EXCEL

En esta ventana los usuarios pueden diseñar planillas de resultadosen excel a su medida. Tambien se puede usar un archivo excel pre-definido como plantilla para titulos y encabezados tal como se puede apreciar en el archivo Plantilla1.xlt que viene en el directorio ejemplos.

Archivo Plantilla: En estas casillas se debe poner el nombre y ruta del archivo que tiene la plantilla sobre la que se escribirán los resultados, y se debe especificar el nombre de la "Hoja de cálculo" que contiene la plantilla dentro de este archivo excel. Si se deja en blanco el nombre del archivo plantilla se escribirán los resultados sobre una planilla en blanco. .

Posición de encabezados: Estos casilleros se especific fila y columna de las celdas en que irán los títulos correspondiente a los casilleros Lote, Obra y Descripción de la pantalla principal del programa.

Disposición de columnas en la Planilla: Este recuadro sirve para especificar el contenido de las columnas en la planilla de resultados. El encabezado de cada columna muestra el nombre de la correspondiente columna de la planilla y la fila central indica el contenido que se escribirá en esa columna. Al apuntar las celdas de la fila central, se despliega un popdown-menu para seleccionar los posibles contenidos de las columnas.

La primera columna de la izquierda tiene el encabezado "Linea Inicio" y es para indicar (en la fila central ) el número de la línea a partir de la cual se comenzaán a escribir los datos de las columnas en la planilla .


Etiquetas Ms Word

DISEÑO DE DETIQUETAS CON MS WORD

Archivo de Etiquetas en MS Word:

Antes de usar esta opción, Ud. debe crear un archivo con la aplicación Ms Word con la plantilla de salida de las etiquetas, usando la herramienta de mezclar correspondencia de Ms Word (Menu: Herramientas / Cartas y correspondencia / combinar correspondencia ). Un ejemplo de esta clase de archivos puede hallar en el directorio 1D-Solutions, el archivo Labels_MergeFile.doc, que se muestra en la figura de arriba.
Así los usuarios `pueden crear sus propieos diseños de etiqueta usando Ms Word.

Archivo de Datos de Etiquetas:

Este archivo es generado por el optimizador cuando la opción "Etiquetas de Ms Word" está seleccionada y el usuario presiona el botón "Solución". Entonces con la aplicación MsWord este archivo es combinado con el archivo plantilla de etiquetas. Los usuarios pueden cambiar el nombre de este archivo o pueden usar el mismo nombre sobreescribiendo el anterior.

Impresión de Etiquetas:

Para imprimir las etiquetas generadas por el optimizador, es necesario usar la opción de impresión que provee la herramienta de combinación de correspondencia. En la barra de herramientas de "combinar correspondencia" aparece el ícono "combinar al imprimir" que hace esta tarea. El botón de impresión corriente de Ms Word solo imprimirá la plantilla.


Stocks de diferente largo

DIFERENTES TIPOS DE BARRAS A CORTAR
 Previous Top

En muchos casos reales se tiene que un fabricante vende material de largo L1 un precio P1 por metro y otro vende el mismo tipo de material a un largo standard L2 a un precio P2 el metro , o bien sucede que hay almacenado un stock de trozos que han sobrado de otros pedidos de corte, los que hay que aprovechar en los pedidos de corte siguientes.

Con el Optimizador Lineal de Corte, podemos determinar el aprovechamiento óptimo económico, cuando los stocks de materiales a cortar no son de largo uniforme y además de diferente costo.

Para ilustrar sigamos con el mismo ejemplo anterior ( Beneficios ). Se quiere dimensionar la cantidad de material de 6m que se va a comprar al fabricante, que son 119 barras de 6m de acuerdo al ejemplo .
Sin embargo, también hay almacenado en bodegas, de 12 trozos sobrantes de 2,5m y 5 trozos sobrantes de 2.02m que se deben aprovechar para desocupar espacio de almacenamiento y comprar menos al fabricante . A estos sobrantes o retales menores usualmente se le asigna una valorización por metro menor que al stock de barras nuevas, en este caso al 85% del precio del material de 6m (su costo es menor en un 15% ).

Entonces en el recuadro del material a cortar queda con estos datos :

( Notese que en la cantidad de barras de 6m disponibles se pone una cantidad muy grande, pues representa la capacidad del fabricante para proveer este material que vamos a comprar)

Resolviendo con estos datos se obtiene un conjunto óptimo de patrones de corte que ocupa 113 barras de 6m y 12 barras de 2,5m ( y no ocupa los trozos de 2.02m).

Si en razón al manejo de stocks de materiales, le resulta aún poco económico mantener esos 5 trozos de 2.02m sin ocupar, entonces eso indica que debemos devalorizar más esos trozos, luego bajando la valorización de estos a un 75%, se obtiene un conjunto óptimo de patrones de corte que ocupa 112 barras de 6m, 12 barras de 5m y 5 barras de 2.02m.


1DNespa

Avanzar a la siguiente celda:

Usar el mouse o presionar la tecla Tab, tambien se pueden usar las teclas flechas Izquierda, Derecha, Arriba y Abajo.

Crear una nueva fila:

Las filas de la grilla se generan si después de posicionar el cursor en la columna "Cantidad" de la última fila, se aprieta la tecla Tab.

Eliminar una fila:

Posicione el cursor sobre una celda de la fila que se desea borrar y presione las teclas Ctrl + Tab o bien Ctrl + Supr.


.topic 170

.topic 180

Avanzar a la siguiente celda:

Usar el mouse o presionar la tecla Tab, tambien se pueden usar las teclas flechas Izquierda, Derecha, Arriba y Abajo.

Crear una nueva fila:

Las filas de la grilla se generan si después de posicionar el cursor en la columna "Cantidad" de la última fila, se aprieta la tecla Tab.

Eliminar una fila:

Posicione el cursor sobre una celda de la fila que se desea borrar y presione las teclas Ctrl + Tab  o  bien Ctrl + Supr.